CVE-2023-4162 - Segmentation fault in Brocade Fabric OS after Brocade Fabric OS v9.0

Brocade Directors

3 more products

22513

16 April 2024

29 August 2023

OPEN

MEDIUM

4.4 - CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H

CVE-2023-4162

Brocade Security Advisory ID

BSA-2023-2367

Component

CLI

 

 

Summary

A segmentation fault can occur in Brocade Fabric OS after Brocade Fabric OS v9.0 and before Brocade Fabric OS v9.2.0a through the passwdcfg command. 
This could allow an authenticated privileged user local user to crash a Brocade Fabric OS swith using the cli “passwdcfg --set -expire -minDiff“.

Note: 
•    The --mindiff option was added in Brocade Fabric OS v9.0. 
•    Only Brocade Fabric OS v9.x are affected

Products Affected

Brocade Fabric OS after Brocade Fabric OS v9.0 and before Brocade Fabric OS v9.2.0a

Products Confirmed Not Affected

Brocade Fabric OS versions before Brocade Fabric OS v9.0 are not affected.

Solution

The security update is provided in Brocade Fabric OS v9.2.0a, v9.1.1d

Credit

The issue was discovered during internal penetration testing. 

Revision History

Version

Change

Date

1.0

Initial Publication

August 29, 2023

2.0

Update for Brocade Fabric OS v9.1.1d

April 11, 2024

 

Disclaimer

THIS DOCUMENT IS PROVIDED ON AN AS-IS BASIS SOLELY FOR INFORMATIONAL PURPOSES AND DOES NOT IMPLY ANY KIND OF GUARANTY OR WARRANTY, INCLUDING THE WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. YOUR USE OF THE INFORMATION CONTAINED HEREIN IS AT YOUR OWN RISK. ALL INFORMATION PROVIDED HEREIN IS BASED ON BROCADE'S CURRENT KNOWLEDGE AND UNDERSTANDING OF THE VULNERABILITY AND IMPACT TO BROCADE HARDWARE AND SOFTWARE PRODUCTS. BROCADE RESERVES THE RIGHT TO CHANGE OR UPDATE THIS DOCUMENT AT ANY TIME.